Método fácil para instalar MailScanner

esta es una forma facilísima de instalar MailScanner en CentOS-6. Primero que todo, debes tener instalado el repositorio de EPEL.

bajamos el tar.gz de CentOS (el primero de la lista) del mailscanner desde

http://www.mailscanner.info/downloads.html

Entonces ejecutamos los siguientes pasos:

yum install perl-Archive-Zip perl-DBI perl-DBD-SQLite perl-Filesys-Df perl-Net-CIDR perl-OLE-Storage_Lite perl-Sys-Hostname-Long perl-Sys-SigAction perl-MIME-tools spamassassin clamav
 

Abrimos el mailscanner que bajamos de la URL inicial y entramos al dierctorio que nos crea:

tar zxf MailScanner*.tar.gz
cd MailScanner*
 

Entonces procedemos a instalar el rpm de tnef y de mailscanner, atención que el número de versión de ambos puede cambiar:

32bits: rpm -Uvh tnef-1.4.5-1.i386.rpm mailscanner-*.noarch.rpm
64bits: rpm -Uvh tnef-1.4.5-1.x86_64.rpm mailscanner-*.noarch.rpm
 

Y listo, al finalizar la instalación me dirá el siguiente paso ahí mismo, pero te lo pongo por si acaso te pierdes:

service sendmail stop
chkconfig sendmail off
service MailScanner start
chkconfig MailScanner on

5 thoughts on “Método fácil para instalar MailScanner”

  1. hola Epe, tengo centos 6 y no hay paquetes para service mailscanner solo con esto ya deberia funcionar el servidor de correo con mailscanner?

  2. Saludos Ernesto, sabe que el repositorio de epel da problemas al instalar clamav, da el siguiente error:

    Error: Package: clamav-0.98.3-1.el5.x86_64 (epel)
    Requires: libcurl.so.3()(64bit)

    Al correr yum –showduplicates list libcurl\*

    devuelve como si estuviera duplicado el repositorio.

    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.globo.com
    * epel: mirror.globo.com
    * extras: mirror.globo.com
    * updates: mirror.globo.com
    Installed Packages
    libcurl.x86_64 7.19.7-37.el6_4 @base
    Available Packages
    libcurl.i686 7.19.7-37.el6_4 base
    libcurl.x86_64 7.19.7-37.el6_4 base
    libcurl-devel.i686 7.19.7-37.el6_4 base
    libcurl-devel.x86_64 7.19.7-37.el6_4 base

    Que se hace en esos casos?

  3. Saludos, creo que el repositorio indicado en el link de arriba funciona mal, le agregue el siguiente y funcionó perfecto.

    CentOS 6 – 32-bit
    rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    CentOS 6 – 64-bit
    rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
    CentOS 5 – 32-bit
    rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
    CentOS 5 – 64-bit
    rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm

Leave a Reply to hc6ep Cancel reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.